Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[2.09 JK-Mod] Fehlermeldung: 'Plugin Exception'
#1
Question 
Tach Apophysianer Big Grin

bei manchen Flames spuckt Apophysis 2.09JK mir diese Fehlermeldung aus:
Zitat:Plugin Exception
Exception in CalcFunction for Plugin "Plugin-Name":
Floating point overflow
Always notify (Y), Always Suppress (N), Supress for Current Render ©
Was passiert da?
Geladen wird es offenbar trotzdem und auch die entsprechende Variation scheint angewendet zu werden. Gut möglich, dass es vielleicht eher so eine Programm-Versions-spezifische Sache ist, denn ich könnte mich eigentlich nicht erinnern, dass mir so etwas in 'Vanilla'-Apophysis oder 7X unter gekommen wäre. Außerdem tritt sie auch nur vereinzelt/sporadisch auf und nicht jedes Mal, wenn das jeweilige Plugin zum Einsatz kommt.

Möglicherweise auch eine Frage der Plugin-Version? Habe kürzlich ein paar Plugins des 'Standard-Packs' (SourceForge-Version) durch welche ersetzt, die etwas neueren Datums zu sein scheinen und (zumindest nach Dateidatum) teilweise auch aktueller sind, als die Programm-Version selbst ...

Hatte diese Meldung schon einige Male bei 'foci', aber gestern war zur Abwechslung mal 'sigmoid' fällig. Smile
Apophysis 7X v.15B | Amberlight 1.2.1 | Mandelbulber 2.11-1 | Explorador FF 7.7 | fr0st 1.4 | Chaoscope 0.3.1
Zitieren
#2
Also ich hatte sowas noch nie, nutze aber auch ausschließlich 7X . Einige Plugins vertragen sich manchmal nicht und es kommt vielleicht drauf an wieviele Plugins verwendet werden.
Könnte aber auch daran liegen - hier ein Ausschnitt vom Einführungstutorial (geschrieben von Biggi):

Es gibt von manchen Plugins mehrere DLL-Dateien mit ähnlichen Namen: (z.B. Flower.dll oder
FlowerVariationPlugin.dll). Da es sich um das gleiche Plugin handelt, darf nur eine von beiden
Versionen im Plugin-Verzeichnis vorhanden sein. In der Regel sind sie gleich.
Fraktale Grüße von ranvaig Smile
Zitieren
#3
Ja, ich bevorzuge auch 7X, nutze die JK-Mod allerdings, wenn ich mit älteren 'Vanilla'-Apo-Flames werkle. Die werden dort anstandslos geladen und sind dann auch identisch. 7X meckert im überwiegenden Teil der Fälle, dass diese oder jene Variation fehlt. Könnte sie wahrscheinlich als Plugin nachinstallieren, aber möchte den 7X-Plugin-Ordner auch nicht allzu sehr überfrachten. Wink

Also, scheint dann ja tatsächlich eher so ein JK-eigenes Ding zu sein. (Das gute Stück ist aber ohnehin manchmal ein bisschen zickig Rolleyes ...) Finde es eigentlich auch eher lästig als schlimm.

Ja, diese Sache mit den 'Doppelversionen' ist mir bekannt. Auch, dass sich generell manche - und selbst unterschiedliche - Plugins nicht so richtig vertragen. Dass die Anzahl der Plugins schonmal Probleme verursachen kann, weil sie nicht richtig geladen werden, habe ich irgendwo gelesen. Habe da jetzt nicht so die Vorstellung: sind ca. 60 Plugins 'viel'?

(Weil du gerade 'Tutorial' erwähnst: kennst du ein gutes Manual oder Wiki (oder auch Tutorials) für Apophysis? Ich kenne zwar die Hilfedateien von Apo 1 und 2, flam3 und habe auch ein paar uralte Tutorials, aber die Hilfedatei von 7X ist eigentlich mit das Aufschlussreichste, was ich in Sachen Dokumentation mein Eigen nenne. Kann auch ruhig in Englisch sein.)
Apophysis 7X v.15B | Amberlight 1.2.1 | Mandelbulber 2.11-1 | Explorador FF 7.7 | fr0st 1.4 | Chaoscope 0.3.1
Zitieren
#4
also ich habe grade in meinem 7X Ordner nachgesehen und habe 61 drin, eigentlich ist das schon völlig überladen. Wenn ich ein neues testen will nehme ich ein weniger wichtiges raus. Ca 40 sollten nach Tutorial drin sein. Apropros`: ich übe nochmal mit dem Dateianhang, das isses dann drin :-)
Schade, obwohl es ein zip is, gehts nich : es kommt die Meldung Datei zu groß
Fraktale Grüße von ranvaig Smile
Zitieren
#5
ranvaig schrieb:also ich habe grade in meinem 7X Ordner nachgesehen und habe 61 drin
Höhö ... ich auch. Big Grin

Na gut: '40' ist doch mal ein Wert, mit dem ich etwas anfangen kann. Habe auch schon die Sachen des 'Standard-Packs' rausgeschmissen, die mich meist ohnehin eher gestört haben, wie etwa die Plugins, die lediglich für Textur-Projektion verantwortlich zu sein scheinen (Mandelbrot, Perlin, etc).

7X kommt mit der vorhandenen Anzahl eigentlich total gut klar.
Allerdings schnurrt die Version 15B hier bei mir ohnehin wie ein Kätzchen - machte bisher noch nie Ärger! Cool  
 
ranvaig schrieb:Schade, obwohl es ein zip is, gehts nich : es kommt die Meldung Datei zu groß
Ist das 'ne .pdf-Datei, die du da mit reingepackt hast? Die können u.U. schon recht groß sein. Weiß aber jetzt auch nicht, was Gerriet hier so als Dateigrößen-Limit für Anhänge festgelegt hat ...
Apophysis 7X v.15B | Amberlight 1.2.1 | Mandelbulber 2.11-1 | Explorador FF 7.7 | fr0st 1.4 | Chaoscope 0.3.1
Zitieren
#6
Ja , is ne pdf Datei mit 4.75 MB, das ganze Tutorialpaket ist 25,5 MB groß. Soweit ich das sehe, ist es im Netz nicht mehr verfügbar. Ich hatte es aus dem jetzt nicht mehr existierenden Fraktal Schmiede Forum vor etwa 5 Jahren runtergeladen
Fraktale Grüße von ranvaig Smile
Zitieren
#7
Ooops ... joa ... 25 mb dürften als Dateianhang definitiv zu groß sein. Smile

Da schreibste was ... mir ist auch schon aufgefallen, dass Suchmaschinen insbesondere in Hinblick auf Fraktale eigentlich nur selten wirklich brauchbare Ergebnisse liefern. Vielleicht liegt's ja daran, dass die entsprechenden Webseiten oft schon älter sind, aber irgendwie ist es doch komisch. (Was habe ich mir bspw. 'nen Wolf nach einer für Windows kompilierten Version von flam3 gesucht Big Grin ...)


PS: Übrigens: falls eine Webseite nicht mehr existiert, du aber den alten Link noch hast, könntest du auch schauen, ob sie vielleicht über die Way Back Machine ([url]https://archive.org/web/[/url]) noch verfügbar ist. Das Internet vergisst so schnell ja nichts. Wink
Apophysis 7X v.15B | Amberlight 1.2.1 | Mandelbulber 2.11-1 | Explorador FF 7.7 | fr0st 1.4 | Chaoscope 0.3.1
Zitieren
#8
nö, habs probiert . is definitiv wech :-( Schön langsam wird mir bewußt, ich hab da ein richtiges Schätzchen und würde es so gerne teilen
Fraktale Grüße von ranvaig Smile
Zitieren
#9
ranvaig schrieb:Schön langsam wird mir bewußt, ich hab da ein richtiges Schätzchen ...
Auf jeden Fall! Big Grin
Bei so etwas ist ein gewisser 'Jäger-und-Sammler'-Trieb mit einem Hang dazu, Dinge zu horten, definitiv eine feine Sache. Bloooß nicht wegwerfen!
ranvaig schrieb:... und würde es so gerne teilen
Naja, ist ja immer so eine Frage, ob das den Urhebern denn so recht wäre. Die Sachen 'persönlich' weiter zu geben ist ja eeeine Sache und dagegen haben die Ersteller ja i.a.R. auch nichts, eine andere, so etwas dauerhaft und allgemein zur Verfügung zu stellen.

Wäre natürlich schön, sowas langfristig hier in der Apo-Sektion (vielleicht in einem gepinnten 'Ressourcen'-Thread oder so) zur Verfügung zu haben, der auch die von dir im anderen Thread angesprochenen Sachen wie Plugins, Skripte, Gradients etc. enthält. Aber dazu müsste datt Zeug ja auch irgendwo gehostet werden. Keine Ahnung, wie Gerriet zu dem Thema steht ... (würde mich aber auch selbst bereit erklären, sowas langfristig auf meinen eigenen Webspace zu laden und dann hier zu verlinken. Aber das sollten wir ggf. erstmal auf jeden Fall mit Gerriet und/oder Andrea bequasseln.)

Was die 'persööönliche' Weitergabe in diesem Fall betrifft, könnte ich dir - so du das tun möchtest - vielleicht via PM oder so auch meine Mailadresse zukommen lassen, an die du's dann als Anhang schicken kannst Wink .. oder falls du 'ne Dropbox hast, vielleicht auch darüber.
Apophysis 7X v.15B | Amberlight 1.2.1 | Mandelbulber 2.11-1 | Explorador FF 7.7 | fr0st 1.4 | Chaoscope 0.3.1
Zitieren
#10
Habe über Tutorials mal ein Thema aufgemacht, habe da auch Links gepostet.
Zu den Plug ins bei Apo, das war für mich .u.a. ein Grund, dass das Programm bei mir schnell wieder vom PC verschwand, mir ist das zu lästig, die Plugins installieren zu müssen. Zudem mag ich keine Programme wo mehree Bei Jwildfire sind die Plugins gleich mit drin. Hat aber dann auch den Nachteil, dass man irgendwann eine große Menge drin hat, da man ja nicht jedes benötigt (war anfangs noch überschaubar, doch mittlerweile ist es etwas chaotisch geworden Big Grin )
Meine Gallery bei Deviantart: http://andrea1981g.deviantart.com/gallery
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste