Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
MutaGenerator und seine Funktionen
#16
Oder es liegt evtl. an der Java-Funktion oder wenn zuviele Formeln vorhanden sind? Hab jetzt das Problem jetzt bei dem 2. Spiel.

Meine Java-Version ist übrigens 8.0.25.18 (komplette Bezeichnung)
Meine Gallery bei Deviantart: http://andrea1981g.deviantart.com/gallery
Zitieren
#17
Ja deine Java Version ist aktuell, aber denke es liegt an java, aber denke das kann der Andreas besser erklären ..
Tschöö

Gerriet | PinguinsReisen.de
Zitieren
#18
Mittlerweile glaub ich nicht mehr, dass es allein an Java liegt, sonst müsste es ja bei euch auch sein, dass der Mutagen sich immer aufhängt und ich ständig Errormeldungen bekommen. Vielleicht liegt es am Virenprogramm (Gdata) oder so, keine Ahnung. (obwohl am Virenprogramm kann es eigentlich auch nicht liegen, denn bei den früheren Versionen von Jwildfire hatte ich nur ganz selten mal Errormeldungen)

EDIT: Habe jetzt mal den Fehlercode aus dem "Stacktrace" kopiert, vielleicht kann Andreas was anfangen, denn jetzt passiert es ja bei jeder Nutzung des Mutagen Sad :
Code:
java.lang.NullPointerException
    at org.jwildfire.create.tina.mutagen.MutaGenController$RenderThread.forceAbort(Unknown Source)
    at org.jwildfire.create.tina.mutagen.MutaGenController.executeRenderThread(Unknown Source)
    at org.jwildfire.create.tina.mutagen.MutaGenController.renderFlame(Unknown Source)
    at org.jwildfire.create.tina.mutagen.MutaGenController.mutate(Unknown Source)
    at org.jwildfire.create.tina.mutagen.MutaGenController.importFlame(Unknown Source)
    at org.jwildfire.create.tina.mutagen.MutaGenController.loadFlameFromEditorBtn_clicked(Unknown Source)
    at org.jwildfire.create.tina.swing.TinaInternalFrame$563.actionPerformed(Unknown Source)
    at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
    at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
    at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
    at java.awt.Component.processMouseEvent(Unknown Source)
    at javax.swing.JComponent.processMouseEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Window.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    at java.awt.EventQueue.access$300(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
    at java.awt.EventQueue$4.run(Unknown Source)
    at java.awt.EventQueue$4.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
Meine Gallery bei Deviantart: http://andrea1981g.deviantart.com/gallery
Zitieren
#19
So, ich krieg jetzt garnichts mehr gerendert mit dem Mutagenerator, jedes Mal erscheint dieses dämliche Meldung. Da muss ich bei den Spielen jetzt mal aussetzen, ich krieg nichts mehr erstellt mit dem Mutagenerator, irgendwas stimmt da nicht!!!!

EDIT:Ich habs jetzt mal ins <!-- m --><a class="postlink" href="http://jwildfire.org-Forum">http://jwildfire.org-Forum</a><!-- m --> gepostet bei den Bugs.
Meine Gallery bei Deviantart: http://andrea1981g.deviantart.com/gallery
Zitieren
#20
Sollte nicht an Java liegen, werde ich mir anschauen...
Hast du eine Flame (parameter), wo es zuverlässig auftritt? Ich hatte dieses Problem nämlich noch nie und kann es bislang nicht nachstellen.
Zitieren
#21
Müsste mal testen, ob es überhaupt noch ein Flame gibt, wo es zuverlässig läuft. Bei einem Fraktal-Spiel ging es einmal einwandfrei, beim nächsten Mal hängt es sich wieder auf.

Habe beim Starten "Memory to use" 1024 MB eingestellt. Ansonsten weiß ich nicht, ob man was einstellen kann, damit es reibungslos läuft.
Meine Gallery bei Deviantart: http://andrea1981g.deviantart.com/gallery
Zitieren
#22
Kurzer Zwischenruf:
Ich habe keinerlei Probleme mit dem "Mutagen"
Beobachten kann ich, wie Andreas schon schrieb, dass es manchmal etwas langsamer läuft.
Andreas Programm stellt einfach hohe Anforderung an den Prozessor,
der bei mir (i5) häufig auf Volllast läuft. (umfangreiche Berechnungen, nehme ich an)
LG Lupo
Zitieren
#23
Ah - jetzt weiß ich warum JW so träge bei mir läuft >Windows.
Ich habe seit 2 Wochen Windows 10 ,einen Arbeitsspeicher von 8 GB und seit vorgestern JW.
Mit meinem alten Rechner habe ich mit JW fast nix gemacht weil ich dachte das liegt an meiner lahmen Kiste.
Jetzt habe ich mit der neuen Kiste genau das gleiche Problem. Sad
JW läuft bei mir lange nicht so zügig wie 7X , oder muß ich mir ein anderes Java zulegen?
Schade - JW find ich nämlich echt genial Smile ( vor allem die neue Version)
Fraktale Grüße von ranvaig Smile
Zitieren
#24
Hier noch mal Daten zu meinem PC, also ich nutze Windows7 (bin ein Gewohnheitstier und möchte ein System solange wie ich klar komme). Habe 8 GB Arbeitsspeicher und ein 64Bit-Betriebssystem. Ich denke doch mal, dass es eigentlich für Jwildfire ausreichen müsste.
Die früheren JWildfire-Versionen liefen allgemein noch schneller, mit dem Verschieben der Regler usw.
Meine Gallery bei Deviantart: http://andrea1981g.deviantart.com/gallery
Zitieren
#25
Vieles lässt sich in den Einstellungen wieder so einstellen, dass es so schnell wie "früher" läuft. Das Programm entwickelt sich ständig weiter und benötigt für neue Funktionen auch mehr "power". Kann man aber meistens abstellen/konfigurieren, dann sollte es wie bisher laufen, wahrscheinlich sogar schneller.
Zitieren
#26
ranvaig schrieb:Ah - jetzt weiß ich warum JW so träge bei mir läuft >Windows.
Ich habe seit 2 Wochen Windows 10 ,einen Arbeitsspeicher von 8 GB und seit vorgestern JW.
Wichtig ist es, ein 64 Bit Java zu verwenden. Wenn es zu langsam ist, spatial oversampling auf 1 setzen.
Wenn es immer noch zu langsam ist, Preview quality verringern und als Random Generator Marsaglia verwenden.
Müsste dann so wie früher laufen.

Gruß
Zitieren
#27
Danke für die Tipps thargor6 Smile dann werd ich das mal ändern Wink
Fraktale Grüße von ranvaig Smile
Zitieren
#28
thargor6 schrieb:Wichtig ist es, ein 64 Bit Java zu verwenden. Wenn es zu langsam ist, spatial oversampling auf 1 setzen.
Wenn es immer noch zu langsam ist, Preview quality verringern und als Random Generator Marsaglia verwenden.
Müsste dann so wie früher laufen.

Gruß
Es hat wohl was gebracht, der Mutagenerator scheint jetzt besser zu laufen, danke für diese hilfreichen Tipps!!!
Meine Gallery bei Deviantart: http://andrea1981g.deviantart.com/gallery
Zitieren
#29
Die nächste Version ist auch in Arbeit, der MutaGen wird dann generell etwas schneller
Zitieren
#30
Hab hier die Probleme gelesen. Selbst arbeite ich immer noch mit der Version 2.23. Da funktioniert alles optimal. Ich rendere - auf die schnelle - immer mit "Render Image" rechts neben dem Vorschaubild. Dann mache ich einen Screenshot und fertig ist mein JW.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste